#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:(My Name is|Me) )(.*?) and (?:my (Hobby|interest) is )([^\\.]*)."
Local $sString = "My Name is Casssandra and my Hobby is Cooking." & @CRLF & _
"My name is Archana and my hobby is Playing.Me Adarsh and my interest is Programming." & @CRLF & _
"Me Leela sharma and my interest is Baking.My name is John and my interest is Gaming." & @CRLF & _
"My name is John and my interest is Singing and Dancing."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")