re = /(?:(My Name is|Me) )(.*?) and (?:my (Hobby|interest) is )([^\\.]*)./mi
str = 'My Name is Casssandra and my Hobby is Cooking.
My name is Archana and my hobby is Playing.Me Adarsh and my interest is Programming.
Me Leela sharma and my interest is Baking.My name is John and my interest is Gaming.
My name is John and my interest is Singing and Dancing.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end