// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:(My Name is|Me) )(.*?) and (?:my (Hobby|interest) is )([^\\.]*).").unwrap();
let string = "My Name is Casssandra and my Hobby is Cooking.
My name is Archana and my hobby is Playing.Me Adarsh and my interest is Programming.
Me Leela sharma and my interest is Baking.My name is John and my interest is Gaming.
My name is John and my interest is Singing and Dancing.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}