const regex = new RegExp('(?:(My Name is|Me) )(.*?) and (?:my (Hobby|interest) is )([^\\\\.]*).', 'gmi')
const str = `My Name is Casssandra and my Hobby is Cooking.
My name is Archana and my hobby is Playing.Me Adarsh and my interest is Programming.
Me Leela sharma and my interest is Baking.My name is John and my interest is Gaming.
My name is John and my interest is Singing and Dancing.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}