import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(src|href)=\"\\/static\\/([^\"]*)\"";
final String string = "<link type=\"text/css\" href=\"/static/assets/vendor/@fortawesome/fontawesome-free/css/all.min.css\" rel=\"stylesheet\">\n"
+ "<link type=\"text/css\" href=\"/static/assets/css/volt.css\" rel=\"stylesheet\">";
final String subst = "$1=\"{% static '$2' %}\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}