import re
regex = re.compile(r"\b(src|href)=\"\/static\/([^\"]*)\"", flags=re.MULTILINE)
test_str = ("<link type=\"text/css\" href=\"/static/assets/vendor/@fortawesome/fontawesome-free/css/all.min.css\" rel=\"stylesheet\">\n"
"<link type=\"text/css\" href=\"/static/assets/css/volt.css\" rel=\"stylesheet\">")
subst = "$1=\"{% static '$2' %}\""
result = regex.sub(subst, test_str)
if result:
print(result)