$re = '/\b(src|href)="\/static\/([^"]*)"/m';
$str = '<link type="text/css" href="/static/assets/vendor/@fortawesome/fontawesome-free/css/all.min.css" rel="stylesheet">
<link type="text/css" href="/static/assets/css/volt.css" rel="stylesheet">';
$subst = "$1=\"{% static '$2' %}\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;