import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<a[^>]*href=\"([^\"]+)\"[^>]*([^<]+).*$";
final String string = "<a href=\"final/main.html\">Multimedia Implementation</a><br/>\n"
+ "<a href=\"final/toc.html\">Table of Contents</a><br/>\n"
+ "<a href=\"final/pref01.html\">About the Author</a><br/>\n"
+ "<a href=\"final/pref02.html\">About the Technical Reviewers</a><br/>\n"
+ "<a href=\"final/pref03.html\">Acknowledgments</a><br/>\n"
+ "<a href=\"final/part01.html\">Part I: Introduction and Overview</a><br/>\n"
+ "<a href=\"final/ch01.html\">Chapter 1. Technical Overview</a><br/>";
final String subst = "<navpoint id=\"n\" playOrder=\"\">\\n<navLabel><text>$2</text></navLabel>\\n<content src=\"$1\" />\\n</navpoint>\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}