#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)rgba?\((?<r>[.\d]+)[, ]+(?<g>[.\d]+)[, ]+(?<b>[.\d]+)(?:\s?[,\/]\s?(?<a>[.\d]+%?))?\)"
Local $sString = "color: rgb(34, 12, 64, 0.6);" & @CRLF & _
"color: rgba(34, 12, 64, 0.6);" & @CRLF & _
"color: rgb(34 12 64 / 0.6);" & @CRLF & _
"color: rgba(34 12 64 / 0.3);" & @CRLF & _
"color: rgb(34.0 12 64 / 60%);" & @CRLF & _
"color: rgba(34.6 12 64 / 30%);" & @CRLF & _
"color: rgba(255, 255, 255);" & @CRLF & _
"color: rgba(255, 255, 255, .5);" & @CRLF & _
"color: rgba(255 255 255 / 0.5);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")