import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rgba?\\((?<r>[.\\d]+)[, ]+(?<g>[.\\d]+)[, ]+(?<b>[.\\d]+)(?:\\s?[,\\/]\\s?(?<a>[.\\d]+%?))?\\)";
final String string = "color: rgb(34, 12, 64, 0.6);\n"
+ "color: rgba(34, 12, 64, 0.6);\n"
+ "color: rgb(34 12 64 / 0.6);\n"
+ "color: rgba(34 12 64 / 0.3);\n"
+ "color: rgb(34.0 12 64 / 60%);\n"
+ "color: rgba(34.6 12 64 / 30%);\n"
+ "color: rgba(255, 255, 255);\n"
+ "color: rgba(255, 255, 255, .5);\n"
+ "color: rgba(255 255 255 / 0.5);";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}