const regex = /rgba?\((?<r>[.\d]+)[, ]+(?<g>[.\d]+)[, ]+(?<b>[.\d]+)(?:\s?[,\/]\s?(?<a>[.\d]+%?))?\)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rgba?\\((?<r>[.\\d]+)[, ]+(?<g>[.\\d]+)[, ]+(?<b>[.\\d]+)(?:\\s?[,\\\/]\\s?(?<a>[.\\d]+%?))?\\)', 'ig')
const str = `color: rgb(34, 12, 64, 0.6);
color: rgba(34, 12, 64, 0.6);
color: rgb(34 12 64 / 0.6);
color: rgba(34 12 64 / 0.3);
color: rgb(34.0 12 64 / 60%);
color: rgba(34.6 12 64 / 30%);
color: rgba(255, 255, 255);
color: rgba(255, 255, 255, .5);
color: rgba(255 255 255 / 0.5);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}