# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"rgba?\((?<r>[.\d]+)[, ]+(?<g>[.\d]+)[, ]+(?<b>[.\d]+)(?:\s?[,\/]\s?(?<a>[.\d]+%?))?\)"
test_str = ("color: rgb(34, 12, 64, 0.6);\n"
"color: rgba(34, 12, 64, 0.6);\n"
"color: rgb(34 12 64 / 0.6);\n"
"color: rgba(34 12 64 / 0.3);\n"
"color: rgb(34.0 12 64 / 60%);\n"
"color: rgba(34.6 12 64 / 30%);\n"
"color: rgba(255, 255, 255);\n"
"color: rgba(255, 255, 255, .5);\n"
"color: rgba(255 255 255 / 0.5);")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.