const regex = /^(?<!\) end).*?\(([\x00-\x27\x2A-\x7F]+?)\) end/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<!\\) end).*?\\(([\\x00-\\x27\\x2A-\\x7F]+?)\\) end', 'gm')
const str = `There are some other sentences before (some otherwords which I am not interested in) all these.This is a sample string (something which I am interested in) end. This is another repeated string (with some otherwords) end.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);