use strict;
my $str = 'There are some other sentences before (some otherwords which I am not interested in) all these.This is a sample string (something which I am interested in) end. This is another repeated string (with some otherwords) end.';
my $regex = qr/^(?<!\) end).*?\(([\x00-\x27\x2A-\x7F]+?)\) end/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";