import re
regex = re.compile(r"^(?<!\) end).*?\(([\x00-\x27\x2A-\x7F]+?)\) end", flags=re.MULTILINE)
test_str = "There are some other sentences before (some otherwords which I am not interested in) all these.This is a sample string (something which I am interested in) end. This is another repeated string (with some otherwords) end."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)