$re = '/^(?<!\) end).*?\(([\x00-\x27\x2A-\x7F]+?)\) end/m';
$str = 'There are some other sentences before (some otherwords which I am not interested in) all these.This is a sample string (something which I am interested in) end. This is another repeated string (with some otherwords) end.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;