#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^^](.*)\n(--+)"
Local $sString = "The case of a file name is one thing, but the case of formatting code in" & @CRLF & _
"a source file is a different matter. Almost all languages have an agreed" & @CRLF & _
"upon style of casing, indentation, etc. You should make a real effort to" & @CRLF & _
"discover the strategy for the language you are using, and to follow it" & @CRLF & _
"as best you can. In this document, I attempt to follow the standards for" & @CRLF & _
"formatting JavaScript code. With a few minor exceptions, if you see me" & @CRLF & _
"vary from what you consider to be the best strategy for formatting" & @CRLF & _
"JavaScript, then please send me email and let me know. My goal is to" & @CRLF & _
"conform to the standards set by the JavaScript community. If I want to" & @CRLF & _
"assert my individuality, I wrote prose or poetry; when I write code, I" & @CRLF & _
"try to conform to standards. The only case for individuality in code is" & @CRLF & _
"the case for writing the cleanest, easiest to understand code of any" & @CRLF & _
"developer on your team. There is no place for a quirky style of" & @CRLF & _
"capitalization or indentation." & @CRLF & _
"" & @CRLF & _
"A Simple JavaScript Development Strategy" & @CRLF & _
"----------------------------------------" & @CRLF & _
"" & @CRLF & _
"JavaScript run in the browser has one set of rules when run in a" & @CRLF & _
"browser, and another set when run outside a browser. If you are using" & @CRLF & _
"JavaScript primarily to write client side scripts meant to be run in a" & @CRLF & _
"browser, then it is best to learn JavaScript, and develop JavaScript," & @CRLF & _
"under that scenario. It is true that there are legitimate and important" & @CRLF & _
"ways to run JavaScript from outside the browser. For instance, you can" & @CRLF & _
"run JavaScript from the command prompt, or directly from inside some" & @CRLF & _
"IDEs. At first, however, such stratagems can lead to much confusion. As" & @CRLF & _
"a result, I suggest that you begin by developing JavaScript inside a" & @CRLF & _
"browser."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")