$re = '/[^^](.*)\n(--+)/m';
$str = 'The case of a file name is one thing, but the case of formatting code in
a source file is a different matter. Almost all languages have an agreed
upon style of casing, indentation, etc. You should make a real effort to
discover the strategy for the language you are using, and to follow it
as best you can. In this document, I attempt to follow the standards for
formatting JavaScript code. With a few minor exceptions, if you see me
vary from what you consider to be the best strategy for formatting
JavaScript, then please send me email and let me know. My goal is to
conform to the standards set by the JavaScript community. If I want to
assert my individuality, I wrote prose or poetry; when I write code, I
try to conform to standards. The only case for individuality in code is
the case for writing the cleanest, easiest to understand code of any
developer on your team. There is no place for a quirky style of
capitalization or indentation.
A Simple JavaScript Development Strategy
----------------------------------------
JavaScript run in the browser has one set of rules when run in a
browser, and another set when run outside a browser. If you are using
JavaScript primarily to write client side scripts meant to be run in a
browser, then it is best to learn JavaScript, and develop JavaScript,
under that scenario. It is true that there are legitimate and important
ways to run JavaScript from outside the browser. For instance, you can
run JavaScript from the command prompt, or directly from inside some
IDEs. At first, however, such stratagems can lead to much confusion. As
a result, I suggest that you begin by developing JavaScript inside a
browser.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);