import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^^](.*)\\n(--+)";
final String string = "The case of a file name is one thing, but the case of formatting code in\n"
+ "a source file is a different matter. Almost all languages have an agreed\n"
+ "upon style of casing, indentation, etc. You should make a real effort to\n"
+ "discover the strategy for the language you are using, and to follow it\n"
+ "as best you can. In this document, I attempt to follow the standards for\n"
+ "formatting JavaScript code. With a few minor exceptions, if you see me\n"
+ "vary from what you consider to be the best strategy for formatting\n"
+ "JavaScript, then please send me email and let me know. My goal is to\n"
+ "conform to the standards set by the JavaScript community. If I want to\n"
+ "assert my individuality, I wrote prose or poetry; when I write code, I\n"
+ "try to conform to standards. The only case for individuality in code is\n"
+ "the case for writing the cleanest, easiest to understand code of any\n"
+ "developer on your team. There is no place for a quirky style of\n"
+ "capitalization or indentation.\n\n"
+ "A Simple JavaScript Development Strategy\n"
+ "----------------------------------------\n\n"
+ "JavaScript run in the browser has one set of rules when run in a\n"
+ "browser, and another set when run outside a browser. If you are using\n"
+ "JavaScript primarily to write client side scripts meant to be run in a\n"
+ "browser, then it is best to learn JavaScript, and develop JavaScript,\n"
+ "under that scenario. It is true that there are legitimate and important\n"
+ "ways to run JavaScript from outside the browser. For instance, you can\n"
+ "run JavaScript from the command prompt, or directly from inside some\n"
+ "IDEs. At first, however, such stratagems can lead to much confusion. As\n"
+ "a result, I suggest that you begin by developing JavaScript inside a\n"
+ "browser.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}