using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<FirstLine>(?<Passport>P)(?<PassportType>.)(?<IssuingCountry>\w{3})(?<PassportOwner>(?<Surname>\w+)<<(?<GivenName>(?:[\w]+<?)+)[<]+))\n(?<SecondLine>(?<PassportNumber>[a-zA-Z0-9<]{9})(?<CheckDigit19>[0-9]{1})(?<Nationality>[A-Za-z]{3})(?<DoB>[0-9]{6})(?<CheckDigit1419>[0-9])(?<Sex>[MF<])(?<Expiral>[0-9]{6})(?<CheckDigit2227>[0-9])(?<PersonalNumber>[\w<]{14})(?<CheckDigit2942>[0-9<])(?<CheckDigitF>[0-9]))$";
string input = @"P<UTOERIKSSON<<ANNA<MARIA<<<<<<<<<<<<<<<<<<<
L898902C<3UTO6908061F9406236ZE184226B<<<<<14
";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}