$re = '/^(?<FirstLine>(?<Passport>P)(?<PassportType>.)(?<IssuingCountry>\w{3})(?<PassportOwner>(?<Surname>\w+)<<(?<GivenName>(?:[\w]+<?)+)[<]+))\n(?<SecondLine>(?<PassportNumber>[a-zA-Z0-9<]{9})(?<CheckDigit19>[0-9]{1})(?<Nationality>[A-Za-z]{3})(?<DoB>[0-9]{6})(?<CheckDigit1419>[0-9])(?<Sex>[MF<])(?<Expiral>[0-9]{6})(?<CheckDigit2227>[0-9])(?<PersonalNumber>[\w<]{14})(?<CheckDigit2942>[0-9<])(?<CheckDigitF>[0-9]))$/m';
$str = 'P<UTOERIKSSON<<ANNA<MARIA<<<<<<<<<<<<<<<<<<<
L898902C<3UTO6908061F9406236ZE184226B<<<<<14
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);