#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bi2\d{3}-\d{1,3}\b"
Local $sString = "i2123-1" & @CRLF & _
"i2121-20" & @CRLF & _
"i2111-331" & @CRLF & _
"i2111" & @CRLF & _
"i21111" & @CRLF & _
"i2111-1141"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")