import re
regex = re.compile(r"\bi2\d{3}-\d{1,3}\b")
test_str = ("i2123-1\n"
"i2121-20\n"
"i2111-331\n"
"i2111\n"
"i21111\n"
"i2111-1141")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")