re = /\bi2\d{3}-\d{1,3}\b/
str = 'i2123-1
i2121-20
i2111-331
i2111
i21111
i2111-1141'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end