const regex = /\bi2\d{3}-\d{1,3}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bi2\\d{3}-\\d{1,3}\\b', 'g')
const str = `i2123-1
i2121-20
i2111-331
i2111
i21111
i2111-1141`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}