package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s|\r)+GO\s*(?:\r|\n)`)
var str = `1111111
GO
222222222
GO
3333333333
GO
444444444444444
GO
55555555555555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}