import re
regex = re.compile(r"(?:\s|\r)+GO\s*(?:\r|\n)")
test_str = ("1111111\n\n"
"GO\n\n"
"222222222\n"
"GO\n"
"3333333333\n\n\n"
" GO \n\n"
"444444444444444\n"
" GO \n\n"
" \n\n"
"55555555555555")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")