using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^| )(?<match>bi-.*?)(?:$|\s)";
string input = @"bi bi-envelope-fill text-red me-2 flex-shrink-0
bi-envelope-fill text-red me-2 flex-shrink-0
bi bi-envelope-fill
bibi-envelope-fill";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}