re = /(?:^| )(?<match>bi-.*?)(?:$|\s)/m
str = 'bi bi-envelope-fill text-red me-2 flex-shrink-0
bi-envelope-fill text-red me-2 flex-shrink-0
bi bi-envelope-fill
bibi-envelope-fill'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end