// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^| )(?<match>bi-.*?)(?:$|\s)").unwrap();
let string = "bi bi-envelope-fill text-red me-2 flex-shrink-0
bi-envelope-fill text-red me-2 flex-shrink-0
bi bi-envelope-fill
bibi-envelope-fill";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}