$re = '/^(\w+)\sq\[(\d+)\]((,)q\[(\d+)\])*;$/m';
$str = 'qreg q[16],q[15];
x q[0];
cx q[4],q[0];
h q[0];
t q[1];
t q[5];
t q[0];
cx q[5],q[1];
cx q[0],q[5];
cx q[1],q[0];
tdg q[5];
cx q[1],q[5];
tdg q[1];
tdg q[5];
';
$subst = "k.gate(\"\1\",\2\4\5)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;