import Foundation
let pattern = #"^(\w+)\sq\[(\d+)\]((,)q\[(\d+)\])*;$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
qreg q[16],q[15];
x q[0];
cx q[4],q[0];
h q[0];
t q[1];
t q[5];
t q[0];
cx q[5],q[1];
cx q[0],q[5];
cx q[1],q[0];
tdg q[5];
cx q[1],q[5];
tdg q[1];
tdg q[5];
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"k.gate("\1",\2\4\5)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)