# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w+)\sq\[(\d+)\]((,)q\[(\d+)\])*;$"
test_str = ("qreg q[16],q[15];\n"
"x q[0];\n"
"cx q[4],q[0];\n"
"h q[0];\n"
"t q[1];\n"
"t q[5];\n"
"t q[0];\n"
"cx q[5],q[1];\n"
"cx q[0],q[5];\n"
"cx q[1],q[0];\n"
"tdg q[5];\n"
"cx q[1],q[5];\n"
"tdg q[1];\n"
"tdg q[5];\n")
subst = "k.gate(\"\\1\",\\2\\4\\5)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.