import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^.]([4][5-9]|[5-9][0-9]|[1][0-9][0-9]|[2][0-4][0-9]|250)";
final String string = "test 45 50 60 70 90 100 110 130 150 200 249 250 260 270 300 400 440 450 \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}