// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^.]([4][5-9]|[5-9][0-9]|[1][0-9][0-9]|[2][0-4][0-9]|250)").unwrap();
let string = "test 45 50 60 70 90 100 110 130 150 200 249 250 260 270 300 400 440 450
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}