const regex = /[^.]([4][5-9]|[5-9][0-9]|[1][0-9][0-9]|[2][0-4][0-9]|250)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^.]([4][5-9]|[5-9][0-9]|[1][0-9][0-9]|[2][0-4][0-9]|250)', 'g')
const str = `test 45 50 60 70 90 100 110 130 150 200 249 250 260 270 300 400 440 450
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}