re = /[^.]([4][5-9]|[5-9][0-9]|[1][0-9][0-9]|[2][0-4][0-9]|250)/
str = 'test 45 50 60 70 90 100 110 130 150 200 249 250 260 270 300 400 440 450
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end