import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?(?:[ ()-]*\\d){10,11}|\\+?(?:[ ()-]*\\d){7}";
final String string = "+79261234567\n"
+ "89261234567\n"
+ "79261234567\n"
+ "9261234567\n"
+ "+7 926 123 45 67\n"
+ "8(926)123-45-67\n"
+ "123-45-67\n"
+ "79261234567\n"
+ "(495)1234567\n"
+ "(495) 123 45 67\n"
+ "89261234567\n"
+ "8-926-123-45-67\n"
+ "8 927 1234 234\n"
+ "8 927 12 12 888\n"
+ "8 927 12 555 12\n"
+ "8 927 123 8 123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}