# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\+?(?:[ ()-]*\d){10,11}|\+?(?:[ ()-]*\d){7}"
test_str = ("+79261234567\n"
"89261234567\n"
"79261234567\n"
"9261234567\n"
"+7 926 123 45 67\n"
"8(926)123-45-67\n"
"123-45-67\n"
"79261234567\n"
"(495)1234567\n"
"(495) 123 45 67\n"
"89261234567\n"
"8-926-123-45-67\n"
"8 927 1234 234\n"
"8 927 12 12 888\n"
"8 927 12 555 12\n"
"8 927 123 8 123")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.