re = /\+?(?:[ ()-]*\d){10,11}|\+?(?:[ ()-]*\d){7}/
str = '+79261234567
89261234567
79261234567
9261234567
+7 926 123 45 67
8(926)123-45-67
123-45-67
79261234567
(495)1234567
(495) 123 45 67
89261234567
8-926-123-45-67
8 927 1234 234
8 927 12 12 888
8 927 12 555 12
8 927 123 8 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end