const regex = /\+?(?:[ ()-]*\d){10,11}|\+?(?:[ ()-]*\d){7}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+?(?:[ ()-]*\\d){10,11}|\\+?(?:[ ()-]*\\d){7}', 'g')
const str = `+79261234567
89261234567
79261234567
9261234567
+7 926 123 45 67
8(926)123-45-67
123-45-67
79261234567
(495)1234567
(495) 123 45 67
89261234567
8-926-123-45-67
8 927 1234 234
8 927 12 12 888
8 927 12 555 12
8 927 123 8 123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}