import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-[^-]{2}-[^-]|-[^-])(?=\\/.*)";
final String string = "H-Foo-Bar-cu-s/9.htm\n"
+ "Some-Thing-sb-s/22297.htm\n"
+ "Foo-Boo-or-Bar-cu-s/553.htm\n"
+ "Random-32-Ness-Can-be-Fun-cu-s/4617.htm\n"
+ "Chicken-Fried-264-Seaturtles-for-Pennies-cu-s/3971.htm\n"
+ "Asymetrical-Banana-Party-p/asy-banana-p.htm";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}