const regex = new RegExp('(-[^-]{2}-[^-]|-[^-])(?=\\/.*)', 'g')
const str = `H-Foo-Bar-cu-s/9.htm
Some-Thing-sb-s/22297.htm
Foo-Boo-or-Bar-cu-s/553.htm
Random-32-Ness-Can-be-Fun-cu-s/4617.htm
Chicken-Fried-264-Seaturtles-for-Pennies-cu-s/3971.htm
Asymetrical-Banana-Party-p/asy-banana-p.htm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}