# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(-[^-]{2}-[^-]|-[^-])(?=\/.*)"
test_str = ("H-Foo-Bar-cu-s/9.htm\n"
"Some-Thing-sb-s/22297.htm\n"
"Foo-Boo-or-Bar-cu-s/553.htm\n"
"Random-32-Ness-Can-be-Fun-cu-s/4617.htm\n"
"Chicken-Fried-264-Seaturtles-for-Pennies-cu-s/3971.htm\n"
"Asymetrical-Banana-Party-p/asy-banana-p.htm")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.