const regex = /^[\W_]+|[\W_]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\W_]+|[\\W_]+$', 'gm')
const str = `'Hello world, josh's car.,'
Hello World.......
..,!Bye World
.???'"""Again, what message should I type here!!!`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);