use strict;
my $str = '\'Hello world, josh\'s car.,\'
Hello World.......
..,!Bye World
.???\'"""Again, what message should I type here!!!';
my $regex = qr/^[\W_]+|[\W_]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";