import Foundation
let pattern = #"^[\W_]+|[\W_]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'Hello world, josh's car.,'
Hello World.......
..,!Bye World
.???'"""Again, what message should I type here!!!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)