#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=Application Name:)[^\n]*(?=[^=]*(?=Secret Key))"
Local $sString = "Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
" Secret Key: XYZ86JBHHSD" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW" & @CRLF & _
" Application Id: XYZ353WERX" & @CRLF & _
" Secret Key: XYZ86JBHHSD" & @CRLF & _
"" & @CRLF & _
"Application Details for the XYZ application:" & @CRLF & _
" =========================================================" & @CRLF & _
"" & @CRLF & _
" Application Name: XYXZW" & @CRLF & _
" Application Id: XYZ353WERX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")