import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Application Name:)[^\\n]*(?=[^=]*(?=Secret Key))";
final String string = "Application Details for the XYZ application:\n"
+ " =========================================================\n\n"
+ " Application Name: XYXZW\n"
+ " Application Id: XYZ353WERX\n"
+ " Secret Key: XYZ86JBHHSD\n\n"
+ "Application Details for the XYZ application:\n"
+ " =========================================================\n\n"
+ " Application Name: XYXZW\n"
+ " Application Id: XYZ353WERX\n\n"
+ "Application Details for the XYZ application:\n"
+ " =========================================================\n\n"
+ " Application Name: XYXZW\n"
+ " Application Id: XYZ353WERX\n"
+ " Secret Key: XYZ86JBHHSD\n\n"
+ "Application Details for the XYZ application:\n"
+ " =========================================================\n\n"
+ " Application Name: XYXZW\n"
+ " Application Id: XYZ353WERX";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}