const regex = /(?<=Application Name:)[^\n]*(?=[^=]*(?=Secret Key))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Application Name:)[^\\n]*(?=[^=]*(?=Secret Key))', 'g')
const str = `Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}